CDM+ 10.1

CDM+ 10.1.9

Submitted by Alex Clay on Wed, 07/11/2018 - 17:26
Release Date

Before installing CDM+ 10.1

Backup your data

Back all databases that will be updated to CDM+ 10.1. If you're on Data Hosting you can contact support to make a backup or simply rely on the nightly backup.

Ensure all computers that will run CDM+ 10.1 meet the system requirements

Please note that Windows XP, Windows Vista, and macOS versions prior to 10.9 are NOT supported.

CDM+ 10.1.8

Submitted by Alex Clay on Tue, 06/26/2018 - 12:41
Release Date

Before installing CDM+ 10.1

Backup your data

Back all databases that will be updated to CDM+ 10.1. If you're on Data Hosting you can contact support to make a backup or simply rely on the nightly backup.

Ensure all computers that will run CDM+ 10.1 meet the system requirements

Please note that Windows XP, Windows Vista, and macOS versions prior to 10.9 are NOT supported.

CDM+ 10.1.7

Submitted by Alex Clay on Tue, 06/19/2018 - 12:41
Release Date

Before installing CDM+ 10.1

Backup your data

Back all databases that will be updated to CDM+ 10.1. If you're on Data Hosting you can contact support to make a backup or simply rely on the nightly backup.

Ensure all computers that will run CDM+ 10.1 meet the system requirements

Please note that Windows XP, Windows Vista, and macOS versions prior to 10.9 are NOT supported.

CDM+ 10.1.6

Submitted by Alex Clay on Wed, 01/03/2018 - 20:34
Release Date

Before installing CDM+ 10.1

Backup your data

Back all databases that will be updated to CDM+ 10.1. If you're on Data Hosting you can contact support to make a backup or simply rely on the nightly backup.

Ensure all computers that will run CDM+ 10.1 meet the system requirements

Please note that Windows XP, Windows Vista, and macOS versions prior to 10.9 are NOT supported.

CDM+ 10.1.5

Submitted by Alex Clay on Wed, 12/06/2017 - 10:19
Release Date

Before installing CDM+ 10.1

Backup your data

Back all databases that will be updated to CDM+ 10.1. If you're on Data Hosting you can contact support to make a backup or simply rely on the nightly backup.

Ensure all computers that will run CDM+ 10.1 meet the system requirements

Please note that Windows XP, Windows Vista, and macOS versions prior to 10.9 are NOT supported.

CDM+ 10.1.4

Submitted by Alex Clay on Mon, 10/23/2017 - 17:17
Release Date

Before installing CDM+ 10.1

Backup your data

Back all databases that will be updated to CDM+ 10.1. If you're on Data Hosting you can contact support to make a backup or simply rely on the nightly backup.

Ensure all computers that will run CDM+ 10.1 meet the system requirements

Please note that Windows XP, Windows Vista, and macOS versions prior to 10.9 are NOT supported.

CDM+ 10.1.3

Submitted by Alex Clay on Wed, 10/04/2017 - 11:56
Release Date

Before installing CDM+ 10.1

Backup your data

Back all databases that will be updated to CDM+ 10.1. If you're on Data Hosting you can contact support to make a backup or simply rely on the nightly backup.

Ensure all computers that will run CDM+ 10.1 meet the system requirements

Please note that Windows XP, Windows Vista, and macOS versions prior to 10.9 are NOT supported.

CDM+ 10.1.2

Submitted by Alex Clay on Tue, 09/05/2017 - 16:36
Downloads
Release Date

Before installing CDM+ 10.1

Backup your data

Back all databases that will be updated to CDM+ 10.1. If you're on Data Hosting you can contact support to make a backup or simply rely on the nightly backup.

Ensure all computers that will run CDM+ 10.1 meet the system requirements

Please note that Windows XP, Windows Vista, and macOS versions prior to 10.9 are NOT supported.

Install CDM+ Mobile 1.9 or later

CDM+ Mobile 1.9 is required to access CDM+ 10.1 databases.

CDM+ 10.1.1

Submitted by Alex Clay on Thu, 08/17/2017 - 20:31
Downloads
Release Date

Before installing CDM+ 10.1

Backup your data

Back all databases that will be updated to CDM+ 10.1. If you're on Data Hosting you can contact support to make a backup or simply rely on the nightly backup.

Ensure all computers that will run CDM+ 10.1 meet the system requirements

Please note that Windows XP, Windows Vista, and macOS versions prior to 10.9 are NOT supported.

Install CDM+ Mobile 1.9 or later

CDM+ Mobile 1.9 is required to access CDM+ 10.1 databases.